这几天天天逛着directadmin的官方论坛,看到这样的一个插件,使用了几天相当不错,发出来给大家看看。
插件原帖地址:http://forum.directadmin.com/showthread.php?t=44743
插件建议要求版本DirectAdmin 1.45.4 以及以上。

CB2.0都有什么内容? (不翻译了,大家能看懂)

Major change: nginx webserver support
Major change: nginx+apache combination support (nginx as a reverse proxy)
Major change: LiteSpeed webserver support (warning: commercial product, so please upload your license key to configure/litespeed before installation) with lsphp support as a PHP mode using LiteSpeed SAPI.
Major change: pigeonhole support
Major change: php-fastcgi support (using mod_fcgid)
Major change: PHP-FPM support was added, new paths to PHP binaries/configs (/usr/local/php53(54))
Major change: mod_ruid2 support was added (you can use it together with suPHP)
Major change: new way of PHP exension installations (using php.conf.d, not the main php.ini), ability to include many new extensions to the future versions of CB
Major change: mysqlnd (MySQL native driver) is used for MySQL, pdo-MySQL and MySQLi in php configuration.
Added htscanner support.
Added suhosin support.
Added zend opcache support.
Added custom_versions.txt support.
Added pigz support (./build pigz).
Added “./build version” to show the CustomBuild version.
Added “./build mysql_backup” to do MySQL backup only (without installation).
Added libxml2, libxslt and clamav files to /configure/ directory, so they are not hardcoded anymore, and there is ability to customize them.
Added automatic upload scans with ClamAV for ProFTPd, Pure-FTPd and PHP (using suhosin).
Dropped mod_perl support.
Added –with-xsl, –enable-soap to PHP configuration files
php1_mode/php2_mode + php1_release/php2_release options.conf settings. php1_release is the main version of PHP, php2 is the additional one.
Major change: if php1/php2_mode is set to suphp, fastcgi or php-fpm, event Apache MPM is used (when no mod_php is selected).
Major change: pureftpd is now the default FTP service. New option: ftpd=pureftpd/proftpd. (replaced old pureftpd=yes/no, proftpd=yes/no)
Added PHP 5.5 support
Added PHP 5.6 support
Using PHP 5.5 as mod_php + mod_ruid2 by default (except FreeBSD systems where PHP 5.5 is installed in suPHP mode without mod_ruid2)
Dropped PHP 4.4, 5.2 support
Dropped Apache 1.3, 2.0, 2.2 support
Dropped MySQL 4.1 support
Dropped UebiMiau and Atmail Open webmail support.
Ability to install PHP 5.3, 5.4 or 5.5 together (2 versions of any combination)
Automatic exim.conf changes after installation/update of ClamAV/SpamAssassin (it uses includes of /etc/exim.spamassassin.conf and /etc/exim.clamav.conf in /etc/exim.conf.

如何升级到CustomBuild 2.0?
1.最好是先执行一些预安装命令,详见官方说明文档:http://help.directadmin.com/item.php?id=354
2.删除原先的版本,升级到2.0

  1. cd /usr/local/directadmin
  2. mv custombuild custombuild_1.x
  3. wget -O custombuild.tar.gz http://files.directadmin.com/services/custombuild/2.0/custombuild.tar.gz
  4. tar xvzf custombuild.tar.gz
  5. cd custombuild
  6. ./build update_da

复制代码

3.打开 /usr/local/directadmin/custombuild/option.conf??,检查默认选项,设置为你想要的相应软件版本,
设置完后,SSH里面执行

  1. ./build options

复制代码

,输入类似以下设置结果,看看是不是跟你预想的一样。

  1. Apache: 2.4.3
  2. Dovecot: 2.1.10
  3. MySQL: 5.5.27
  4. PHP (default): 5.4.7 as mod_php
  5. Run “clean” every time: yes

复制代码

确认没错,然后执行。

  1. ./build apache
  2. ./build php n
  3. ./build rewrite_confs

复制代码

当然你也可以全部重建,

  1. ./build all d

复制代码

 

注意事项:
如果选择安装nginx,php模式选择php-fpm,
不可同时将php1_release和php2_release设置为相同版本。
如果设置了php2_release,不可同时设置php1_mode和php2_mode为mod_php
不可把mod_ruid2和php-fpm或者php-fastcgi同时使用。

到这里只是完成安装CustomBuild 2.0,为了后续操作方便,我们今天要重点介绍插件CustomBuild 2.0 UI,图形化操作界面。
该插件由smtalk 一个活跃在DA官方论坛的技术人员开发,在论坛里面有问必答。(说真的,国外的技术论坛跟国内的差距就是很大啊!)
插件发布页面:CustomBuild 2.0 UI??http://forum.directadmin.com/showthread.php?t=48989

大家可以直接进入DA后台插件目录,直接通过连接安装,或者是下载到本地然后上传到DA插件目录里面。
插件下载地址:http://www.custombuild.eu/plugin/custombuild.tar.gz

如果你执行了我以上说升级CB2.0以及build Apache以及php两个软件,那你安装这个插件后,应该可以看到这个界面。
01

点击链接后,显示的是这样

02

在这个界面里面可以完成所有需要通过命令行才能执行的custombuild的相关操作,比如升级版本,选择对应版本等等操作,功能十分强大。
具体还要大家自己去尝试。
03
04

执行命令是显示的类似如下图效果,
05

这下妈妈不用担心我重建系统时SSH卡掉线了!。。

首页

No Comments Now!

Be the first to comment on this entry.

留下评论

姓名(必填)
Mail (必填),(will not be published)
站点(recommended)

Fields in bold are required. Email addresses are never published or distributed.

Some HTML code is allowed:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>
URLs must be fully qualified (eg: http://www.hexiaoqun.com),and all tags must be properly closed.

Line breaks and paragraphs are automatically converted.

Please keep comments relevant. Off-topic, offensive or inappropriate comments may be edited or removed.